PAR Payment Services is happy to announce our new PAR Payment Services Portal is now live. Users will simply need to log out and log back in to access the new portal.
The new PAR Payment Services portal will include a fresh look and feel with updated navigation and new elements such as Location / Merchant ID Selector and Updated / Revised Filtering.
To help with the transition we will be keeping the legacy PAR Payment Services portal available until Friday, June 13th, 2025. To navigate back to the legacy portal, you will simply need to select the “Switch to Legacy” button on the top border of the screen.
Should you have any questions or concerns please feel free to contact the PAR Payment Services team at: paymentservices@partech.com . Please be sure to include your Merchant ID and Support Related concern.
Posted Mar 31, 2025 - 09:09 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 31, 2025 - 09:00 PDT
Update
Dear Valued Customer,
PAR Payment Services is happy to announce the upcoming release of our new PAR Payment Services Portal. The new portal will be enabled today, Monday, March 31st, 2025, at 10:00 AM MST. At the time or the release users will simply need to log out and log back in to access the new portal.
The new PAR Payment Services portal will include a fresh look and feel with updated navigation and new elements such as Location / Merchant ID Selector and Updated / Revised Filtering.
To help with the transition we will be keeping the legacy PAR Payment Services portal available until Friday, June 13th, 2025. To navigate back to the legacy portal, you will simply need to select the “Switch to Legacy” button on the top border of the screen.
Should you have any questions or concerns please feel free to contact the PAR Payment Services team at: paymentservices@partech.com . Please be sure to include your Merchant ID and Support Related concern.
Posted Mar 31, 2025 - 05:48 PDT
Update
Dear Valued Customer,
PAR Payment Services is happy to announce the upcoming release of our new PAR Payment Services Portal. The new portal will be enabled on Monday, March 31st, 2025, at 10:00 AM MST. At the time or the release users will simply need to log out and log back in to access the new portal.
The new PAR Payment Services portal will include a fresh look and feel with updated navigation and new elements such as Location / Merchant ID Selector and Updated / Revised Filtering.
To help with the transition we will be keeping the legacy PAR Payment Services portal available until Friday, June 13th, 2025. To navigate back to the legacy portal, you will simply need to select the “Switch to Legacy” button on the top border of the screen.
Should you have any questions or concerns please feel free to contact the PAR Payment Services team at: paymentservices@partech.com . Please be sure to include your Merchant ID and Support Related concern.
Posted Mar 25, 2025 - 09:09 PDT
Update
Dear Valued Customer,
PAR Payment Services is happy to announce the upcoming release of our new PAR Payment Services Portal. The new portal will be enabled on Monday, March 31st, 2025, at 10:00 AM MST. At the time or the release users will simply need to log out and log back in to access the new portal.
The new PAR Payment Services portal will include a fresh look and feel with updated navigation and new elements such as Location / Merchant ID Selector and Updated / Revised Filtering.
To help with the transition we will be keeping the legacy PAR Payment Services portal available until Friday, June 13th, 2025. To navigate back to the legacy portal, you will simply need to select the “Switch to Legacy” button on the top border of the screen.
Should you have any questions or concerns please feel free to contact the PAR Payment Services team at: paymentservices@partech.com . Please be sure to include your Merchant ID and Support Related concern.
Posted Mar 24, 2025 - 06:13 PDT
Update
Dear Valued Customer,
PAR Payment Services is happy to announce the upcoming release of our new PAR Payment Services Portal. The new portal will be enabled on Monday, March 31st, 2025, at 10:00 AM MST. At the time or the release users will simply need to log out and log back in to access the new portal.
The new PAR Payment Services portal will include a fresh look and feel with updated navigation and new elements such as Location / Merchant ID Selector and Updated / Revised Filtering.
To help with the transition we will be keeping the legacy PAR Payment Services portal available until Friday, June 13th, 2025. To navigate back to the legacy portal, you will simply need to select the “Switch to Legacy” button on the top border of the screen.
Should you have any questions or concerns please feel free to contact the PAR Payment Services team at: paymentservices@partech.com . Please be sure to include your Merchant ID and Support Related concern.
Posted Mar 24, 2025 - 06:11 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 17, 2025 - 06:41 PDT
Scheduled
Dear Valued Customer,
PAR Payment Services is happy to announce the upcoming release of our new PAR Payment Services Portal. The new portal will be enabled on Monday, March 31st, 2025, at 10:00 AM MST. At the time or the release users will simply need to log out and log back in to access the new portal.
The new PAR Payment Services portal will include a fresh look and feel with updated navigation and new elements such as Location / Merchant ID Selector and Updated / Revised Filtering.
To help with the transition we will be keeping the legacy PAR Payment Services portal available until Friday, June 13th, 2025. To navigate back to the legacy portal, you will simply need to select the “Switch to Legacy” button on the top border of the screen.
Should you have any questions or concerns please feel free to contact the PAR Payment Services team at: paymentservices@partech.com . Please be sure to include your Merchant ID and Support Related concern.
Posted Mar 17, 2025 - 06:41 PDT
This scheduled maintenance affected: PAR Payment Services.